
LESSON 5: TEST 02: t-Test (Part I) 

Now	,	let’s	move	to	a	bit	more	complicated	matters	and	see	how	to	compare	two	groups	under	
two	different	conditions,	which	is	a	common	scenario	in	the	field	of	TEFL.	For	that	we	will	need	
to	run	a	t‐test.		
Researchers often aim to analyze differences among groups, particularly in experimental research 
where manipulating variables allows causal inferences. The simplest form of experimentation 
involves a single independent variable manipulated in two ways, measured against a single 
outcome. Frequently, this manipulation involves an experimental condition and a control group. 
For instance, consider scenarios like comparing teaching methods, assessing vocabulary training 
techniques, or evaluating learning app outcomes in TEFL research. In these scenarios, researchers 
manipulate variables (like teaching methods or learning tools) and analyze their impact on 
outcomes. The aim is to discern significant differences between different approaches to language 
learning and teaching. 
Here, I will elaborate on each of these scenarios for a better understanding. 
 

1. Comparing the Effectiveness of Two Teaching Methods: 
 
Scenario: In a TEFL program, an educator is exploring the efficacy of two different teaching 
methods for enhancing speaking skills among intermediate-level students. The methods include a 
traditional lecture-based approach and an interactive conversational learning approach. The 
educator designs two groups, one taught using the lecture-based method and the other with the 
conversational method, and administers speaking assessments before and after the teaching 
period. 
 
Research Question: Is there a significant difference in the improvement of 
 speaking skills between students taught through the lecture-based approach and those taught 
through the conversational approach in the TEFL program? 
 

2. Assessing the Impact of Vocabulary Training Techniques: 
 
Scenario: A researcher in TEFL settings is investigating the effectiveness of two vocabulary 
training techniques—flashcards and mnemonic devices—on enhancing vocabulary retention 
among beginner-level language learners. Participants are randomly assigned to either the 
flashcards group or the mnemonic devices group and undergo a vocabulary test before and after 
the training period. 
Research Question: Is there a significant difference in the post-training vocabulary scores between 
language learners using flashcards and those using mnemonic devices in the TEFL program? 
 

3. Comparing the Learning Outcomes of Language Apps:  
 
Scenario: In a language institute, researchers are interested in comparing the language proficiency 
outcomes of students using two different language learning apps over a semester. Students are 
divided into two groups, one using App A and the other using App B, and their language 
proficiency is assessed at the beginning and end of the semester. 
Research Question: Is there a significant difference in language proficiency gains between 
students using App A and those using App B in the TEFL program? 
 



These scenarios illustrate how t-tests can be applied in TEFL research to compare the effectiveness 
of teaching methods, training techniques, or learning tools to discern any significant differences 
between different approaches in language learning and teaching. 
 

Types of t-tests: 
There are two types: the Independent-samples t-test, used when different participants are 
assigned to distinct conditions, and the Dependent or Paired-samples t-test, applied when the 
same participants are involved in both conditions of the experiment. These tests are fundamental 
in determining if there are statistically significant differences between experimental conditions in 
TEFL research. 
Note that in the field of TEFL, you might be required to run both the dependent and the 
independent t-tests within the same experimental research. HOW? Let’s elaborate more on the 3rd 
scenario above about the two Apps using the figure below: 
 
 
Pre-test mean score App A     Post-test mean score for App A 
 
 
 
 
 
 
 
Pre-test mean score App B      Post-test mean score for App B 
 
   

Rationale for the t-test : 
 

The rationale behind both types of t-tests revolves around hypothesis testing. When collecting 
two sets of data and calculating their means, these means might slightly or significantly differ. If 
these samples originate from the same population, we anticipate their means to be roughly 
similar. Under the null hypothesis—assuming no effect of the experimental manipulation—we 
expect close similarity in sample means. By comparing the observed difference between sample 
means with the expected difference, we can infer two possibilities: 

• No effect exists, and the sample means represent atypical fluctuations within the 
population. 

• The samples belong to different populations, showing a genuine difference between them, 
thereby questioning the null hypothesis. 

 But what is the mean score? 
A mean score, commonly termed the arithmetic average, is computed by summing all values within a 
set of numbers and dividing the total by the count of values. Often regarded as a measure of central 
tendency, the mean represents the typical or most representative value within a dataset. 

 
Assumptions of the t-test: 

 

Both the independent t-test and the dependent (paired-samples) t-test are parametric tests based 
on the normal distribution and, therefore, they assume: 
1- data are from normally distributed populations. 
2- data are measured at least at the interval level. 
Because it is used to test different groups of people, the independent test also assumes: 
3- variance in these populations are roughly equal (homogeneity of variance) 
4- scores are independent (because they come from different people)  
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Testing for Normality using SPSS Statistics 
Assessing data normality is crucial for many statistical tests that rely on this assumption. There are 
two main approaches to determine normality: graphical and numerical. Graphical methods 
involve assessing plots or graphs, offering subjective judgment, while numerical tests offer an 
objective assessment but might lack sensitivity with small sample sizes or become too sensitive 
with larger ones. Individuals with less experience in graphical interpretation may prefer relying 
on numerical methods for assessing normality. In SPSS Statistics, comprehensive step-by-step 
guides are available for testing normality and handling situations where data violates the 
normality assumption, including transformations to achieve normality. 
 

Methods of assessing normality 
SPSS Statistics offers the Explore... command to test procedures related to normality. When 
evaluating normality within one group or multiple groups in a dataset, Explore... command can be 
used. For instance, determining if participants' height data is normally distributed can be 
accomplished using Explore... If the dataset is split by categorical variables like gender (male and 
female), the Explore... command helps test the normality of height within each group separately. 
However, when dealing with multiple categorical independent variables, Explore... command 
alone might not suffice, necessitating the use of the Split File... command. 
 

Procedure for none or one grouping variable 
 
In this section we will use the example of the duration of a given course (let’s say speaking 
course). Time would stand as the dataset we are interested in determining the normality (or 
otherwise). The categorical variables that may split our dataset would be the course level 
(beginner, intermediate, and advanced) 

1. Click Analyze > Descriptive Statistics > Explore... on the top menu, as shown below: 

 



2. You will be presented with the Explore dialogue box, as shown below: 

 

3. Transfer the variable that needs to be tested for normality into the Dependent List: box by 

either drag-and-dropping or using the  button. In this example, we transfer 
the Time  variable into the Dependent List: box. You will then be presented with the 
following screen: 

 

4. [Optional] If you need to establish if your variable is normally distributed for each level of 
your independent variable, you need to add your independent variable to the Factor 

List: box by either drag-and-dropping or using the  button. In this example, we transfer 
the Course  variable into the Factor List: box. You will be presented with the following 
screen: 



 

Click on the  button. You will be presented with the Explore: Statistics dialogue 
box, as shown below: 

 

Leave the above options unchanged and click on the  button. 

5. Click on the  button. Change the options so that you are presented with the 
following screen: 

 



6. Click on the  button. 

7. Click on the  button. 

 
 
 
 
 
Output 

SPSS Statistics outputs many table and graphs with this procedure. One of the reasons for this is 
that the Explore... command is not used solely for the testing of normality, but in describing data 
in many different ways. When testing for normality, we are mainly interested in the Tests of 
Normality table and the Normal Q-Q Plots, our numerical and graphical methods to test for the 
normality of data, respectively. 

Kolmogorov-Smirnov and Shapiro-Wilk Test of Normality 

 

The above table presents the results from two well-known tests of normality, namely the 
Kolmogorov-Smirnov Test and the Shapiro-Wilk Test. The Shapiro-Wilk Test is more appropriate 
for small sample sizes (< 50 samples), but can also handle sample sizes as large as 2000. For this 
reason, we will use the Shapiro-Wilk test as our numerical means of assessing normality. 

We can see from the above table that for the "Beginner", "Intermediate" and "Advanced" Course 
Group the dependent variable, "Time", was normally distributed. How do we know this? If 
the Sig. value of the Shapiro-Wilk Test is greater than 0.05, the data is normal. If it is below 0.05, 
the data significantly deviate from a normal distribution. 

Normal Q-Q Plot 

In order to determine normality graphically, we can use the output of a normal Q-Q Plot. If the 
data are normally distributed, the data points will be close to the diagonal line. If the data points 
stray from the line in an obvious non-linear fashion, the data are not normally distributed. As we 
can see from the normal Q-Q plot below, the data is normally distributed. If you are at all unsure 
of being able to correctly interpret the graph, rely on the numerical methods instead because it can 
take a fair bit of experience to correctly judge the normality of data based on plots. 



 

Procedure when there are two or more independent variables 

The Explore... command on its own cannot separate the dependent variable into groups based on 
not one but two or more independent variables. However, we can perform this by using the Split 
File... command. 

1. Click Data > Split File... on the top menu as shown below: 

 

2. You will be presented with the Split File dialogue box, as shown below: 



 

3. Click the option, Organize output by groups. Transfer the independent variables you wish to 
categorize the dependent variable on into the Groups Based on: box. In this example, we 
want to know whether interest in politics ( Int_Politics ) is normally distributed when 
grouped/categorized by Gender  AND Edu_Level  (education level). You will be presented 
with the following screen: 

 

4. Click on the  button. 

Note: Your file is now split and the output from any tests will be organized into the groups you 
have selected. 

1. Click Analyze > Descriptive Statistics > Explore... on the top menu as shown below: 



 

2. You will be presented with the Explore dialogue box, as shown below: 

 

3. Leave the above options unchanged and click on the  button. 

4. Transfer the variable that needs to be tested for normality into the Dependent List: box by 

either drag-and-dropping or using the  button. In this example, we transfer 
the Int_Politics variable into the Dependent List: box. You will then be presented with the 
following screen: 



 

Note: There is no need to transfer the independent variables Gender and Edu_Level into 
the Factor List: box because this has been accomplished with the Split File... command. We 
cannot simply transfer these two independent variables into the Factor List: box because this 
will not achieve the desired result. It will first analyse Int_Politics for normality with respect 
to Gender and then with respect to Edu_Level. It does NOT analyse Int_Politics for 
normality by grouping individuals into both Gender and Edu_Level AT THE SAME TIME. 

5. Click on the  button. You will be presented with the Explore: Statistics dialogue 
box, as shown below: 

 

6. Leave the above options unchanged and click on the  button. 

7. Click on the  button. Change the options so that you are presented with the 
following screen: 



 

8. Click on the  button. 

Click on the  button. 
 


